Start here
Autopilot
Autopilot is a continually learning real-time general playtesting system. It supports Unreal Engine 5, Unity 6, and Godot 4 on both Windows and macOS.
Installation
Installing pre-built packages
-
Download the latest Autopilot build for your game engine and OS from tryaura.dev/autopilot.
-
Install Autopilot into your project.
Unreal (v5.4-5.8)
- Unzip the download. Move
Autopilot/into your project'sPlugins/folder (create aPlugins/folder yourself if your project doesn't have one yet). You should therefore have<YourProject>/Plugins/Autopilot/Autopilot.uplugin. - Open your project. Click the orange Autopilot icon to open Autopilot.
Unity (v6 or later)
- Unzip the download. It should contain the file
com.ramenvr.autopilot-<version>.tgz. - Open your project. In Window > Package Management > Package Manager, choose + > Install package from tarball..., and pick that file.
- Open Window > Autopilot.
Godot (v4.7 or later)
- Unzip the download. Move
autopilot/into your project'saddons/folder. - Open your project. Enable Autopilot in Project > Project Settings > Plugins. The Autopilot dock appears on the right.
- Unzip the download. Move
-
Follow the Autopilot setup flow.
- We recommend using Autopilot with your Aura account. Click Create Account if you don't yet have an Aura account, or Sign in if you are a returning user.
- Autopilot runs its setup, and finally redirects you to the signup/signin page. Complete your signin/signup process.
- Upon successful authentication, you should see the "Agent service ready" page. Click Continue.
- You have the option to enable/disable sharing your runs to improve Autopilot. As the developers of Autopilot, we would of course appreciate your enabling this!
- (Optional) Run the 10-minute exploration run to populate your Autopilot project memory. It is safe to skip this and jump straight to sending your own prompt.
- Prompt Autopilot! See the types of prompts you can try in Usage.
Installing from source
You can install Autopilot from source. This is supported for Unreal Engine only. This method allows you to build Autopilot against an Unreal source build, and places the Autopilot plugin into your Unreal project's Plugins folder automatically.
git clone https://github.com/ramenvr/autopilot.git
cd autopilot
powershell -ExecutionPolicy Bypass -File tools\build_unreal.ps1 `
-EngineDir "C:\path\to\UnrealEngine" `
-PluginsDir "C:\path\to\YourProject\Plugins"
Once that has completed, follow the Autopilot setup flow as shown in Step 3 of Installing pre-built packages.
Usage
The main way to use Autopilot is through the Autopilot plugin in your editor. This works in Unreal Engine 5, Unity 6, and Godot 4 on both Windows and macOS. This path uses your Aura plan, or your BYOK API keys.
Alternative ways to use Autopilot include:
- In Aura: You can also use Autopilot in Aura. Only Unreal and Unity are supported through this path. This path uses your Aura plan.
- In Claude Code / Codex: You can use Autopilot through Claude Code and Codex via Autopilot's skills and MCP server. To set this up, run
autopilot connect claudeand/orautopilot connect codexin your terminal, then prompt Claude Code / Codex to "Use Autopilot to ...". This path uses your own Claude/ChatGPT subscription.
An Autopilot prompt is one of 4 types:
- Exploration, e.g. "Explore the crafting system in Lvl_Main."
- Testing, e.g. "Go through the currently open level and tell me everything that looks wrong."
- Verification, e.g. "Verify that the tree shakes when you hit it with an axe."
- Goal, e.g. "Kill the boss while keeping your health above 20% of its maximum value."
For every prompt, Autopilot will automatically launch a PIE window and start reading your project's source code, probe PIE, and start playing according to your prompt. Once it is done, the PIE window will close automatically, and Autopilot generates a report for you.
Uninstallation
- In Autopilot, go to Settings and click Uninstall. By default, Autopilot keeps your project's memories; you can choose to delete memories instead (this is a destructive action).
- Remove the plugin from each project:
- Unreal: close the editor and delete
Plugins/Autopilot/. - Unity: remove the Autopilot package in the Package Manager.
- Godot: disable Autopilot in Project > Project Settings > Plugins, then delete
addons/autopilot/.
- Unreal: close the editor and delete